Forums

Solved one problem, found another

  1. I installed the WP app on my phone and was not able to log in due to my hosting company's restrictions regarding XMLRPC. After consulting with them, I wrote an htaccess file and now I'm able to log in.

    But whenever I try to post i get the same error - 'not found.'

    Is there some config on the app that I'm missing? I suspect it may be the API key, but even after creating a free Wordpress account and logging in, I'm not able to find the API key - the only thing I get is the Askimet option, which is way beyond my price point.

    Any help would be appreciated. Thanks!

    Don

  2. Update: I went to the Wordpress API key page and got my API key (it hadn't appeared there before but showed up today).

    Entered it into my phone, tried a test post and still got the 'not found' error. What else am I missing here?

  3. I suggest you to test your site on the following XML-RPC validator: http://www.eritreo.it
    The Wordpress.com API key is not required to publish a post on a self-hosted site.

  4. Everything checks out there. I went back and checked xmlrpc.php and realized I had renamed it when it was initially not working. Thank you for the link!

    I tested a post and it worked, but it saved as a draft. Is there a WP setting that will make posts automatically go live rather than as a draft?

    Thanks again.

    Don

  5. Make sure to click the 'Publish' button, the 2nd button on the toolbar. If that doesn't help, double check the datetime settings on your device and on your blog.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags

No tags yet.